Repeater Troubleshooting

  1. Sensors not showing up in event logs/tripping in system
    • Make sure Repeater is properly added to system, take off panel wait for tamper message to show on tablet, then reclose
    • Make sure Repeater is within 30 ft. of base and sensor is within 30 feet of Repeater.
  2. Repeater not powering on, or indicator lights not coming on.
    • Make sure Repeater power supply is plugged into a working A/C outlet
    • Make sure battery is seated correctly
  3. Error Message : Low Battery
    • Ensure the battery tab has been pulled to allow for contact before closing the back battery compartment.
    • Make sure battery is seated with poles aligned correctly.
    • If the battery charge has been completely drained, allow battery charge by leaving it in place correctly for 12 hours.
    • If A/C power is removed after 12 hours and Repeater powers of, replace battery.
  4. Repeater Not adding to system
    • Check tablet firmware and Base firmware to ensure they are compatible builds and the latest version.
    • Make sure Repeater is within 30 ft. of base.
  5. Disabling Sounds coming from Repeater
    • On the Security Touchpad swipe to the left then select “Settings”, enter the Master code if prompted.
    • From the settings Menu, make sure “Devices” is highlighted in the left hand column.
    • Tap on the Repeater in the middle column that you wish to disable sound from.
    • On the right hand column you will be able to toggle the Repeater sounds on and off.
  6. Deleting a Repeater
    • On the Security Touchpad swipe to the left then select “Settings”, enter the Master code if prompted.
    • From the settings Menu, make sure “Devices” is highlighted in the left hand column.
    • Tap on the Repeater in the middle column that you wish to delete.

At the top of the left hand column you will see a delete button for the Repeater. Select and confirm with pop up message.